2D Liquefaction Analysis for Bridge Abutment

Tutorial by Angel Francisco Martinez

Integrated Solver Optimized for the next generation 64-bit platform

Finite Element Solutions for Geotechnical Engineering
Introduction

- Soil liquefaction is a phenomenon in which the strength and stiffness of a saturated soil/sand is reduced by earthquake shaking or other rapid loading.
- The pressures generated during large earthquake shaking can cause the liquefied sand and excess water to force its way to the ground surface.
- Soil particles can no longer support all the weight.
- Bridges and large buildings constructed on pile foundations may lose support from the adjacent soil and come to rest at a tilt after shaking.
- Sloping ground and ground next to rivers and lakes may slide on a liquefied soil layer (‘lateral spreading’).

2D Seismic Analysis Methods

- **Pseudostatic Analysis**
  - Limit Equilibrium Method
    + MIDAS Soilworks
    + Slide
- **Numerically Based Analysis**
  - Finite Element Method
    + MIDAS GTS NX
    + Quake/W
    + Plaxis
  - Finite Difference Method
    + FLAC

Pseudostatic Analysis

- Representation of the complex, transient, dynamics of earthquake shaking by a single, constant, unidirectional load is crude.
- Method has been shown to be unreliable for soils with significant pore pressure buildup during cycling (i.e., not valid for liquefaction).
- Cannot predict deformation.
- Is only a relative index of slope stability.
- Outdated and should only be used for screening purposes.
- More elaborate techniques are generally warranted and are rather easy to do with modern computing software.
Advanced Numerical Methods

- Based on finite difference or finite element techniques
- Full dynamics modeled
- Deformation can be estimated using elasto-plastic or other constitutive models
- Required advanced training and Coding for FLAC models

**FDM**

**FEM**
2D Liquefaction Analysis of Bridge Abutment

Objectives

1. Plane strain elements are used to model both the ground conditions and Abutment.
2. Pile elements are modeled as beam elements and embedded in Embankment, UBC Sand, and Soft Rock layers.
3. Model the load in surrounding ground generated by earthquake and evaluate dynamic behavior and vibration effect of ground and abutment.
4. Check the eigenvalue of ground through Eigenvalue analysis, Analyze ground dynamic behavior affected by earthquake.
5. Starting Files Required: GTS NX 2D liquefaction tutorial_start.gtb
6. Check Liquefied Layers
1. Main Menu > File>Open...
2. Double click ‘GTS NX 2D liquefaction_start.gtb
3. Main Menu > Analysis > Setting > Unit System> kN>m>s
4. Click [OK].

Procedure
## Materials

<table>
<thead>
<tr>
<th>ID</th>
<th>Name</th>
<th>Type</th>
<th>Modulus of Elasticity (E) [kN/m²]</th>
<th>Poisson’s Ratio (ν)</th>
<th>Unit Weight (Y) [kN/m³]</th>
<th>Unit Weight (Saturated) [kN/m³]</th>
<th>Cohesion (c) [kN/m²]</th>
<th>Friction Angle [°]</th>
<th>K₀</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Embankment</td>
<td>Mohr Coulomb</td>
<td>40,000</td>
<td>0.35</td>
<td>18</td>
<td>19</td>
<td>15</td>
<td>25</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Liquefaction</td>
<td>UBC SAND</td>
<td>60,000</td>
<td>0.02</td>
<td>20</td>
<td>21</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>3</td>
<td>Weathered Rock</td>
<td>Mohr Coulomb</td>
<td>100,000</td>
<td>0.3</td>
<td>20</td>
<td>21</td>
<td>35</td>
<td>33</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>Soft Rock</td>
<td>Mohr Coulomb</td>
<td>900,000</td>
<td>0.25</td>
<td>24</td>
<td>25</td>
<td>150</td>
<td>37</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>Abutment</td>
<td>Mohr Coulomb</td>
<td>21,000,000</td>
<td>0.18</td>
<td>25</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>6</td>
<td>Pile</td>
<td>Elastic</td>
<td>210,000,000</td>
<td>0.3</td>
<td>78</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>
The Modified UBCSAND model is developed to simulate liquefaction phenomenon using **plastic theory based on explicit method for 2D effective stress state**. It is extended to enable **implicit nonlinear analysis for 3D stress state** based on the constitutive model\(^9, 10\)

In elastic region, nonlinear elastic behavior can be simulated, elastic modulus changes according to the effective pressure applied. In **plastic region, the behavior is defined by three types of yield functions**: shear (shear hardening), compression (cap hardening), and pressure cut-off. In case of shear hardening, soil densification effect can be taken into account by cyclic loading.

* Note - **Implicit Method**: Explicit methods calculate the state of a system at a later time from the state of the system at the current time, while implicit methods find a solution by solving an equation involving both the current state of the system and the later one.

---

Drainage parameters

The pore water pressure in stress analysis can be divided into normal state pore water pressure and abnormal state pore water pressure - the excess pore water pressure generated between soil particles due to external loading under undrained conditions. An excess pore water pressure of nearly 0 is called the drainage condition.

Undrained Material Type: Effective stiffness/effective strength

This is the most general case where the input stiffness parameters and strength parameters are the parameters of the ground skeleton. Like drained analysis, GTS NX uses the input stiffness/strength parameters for undrained analysis. The disadvantage is that the effective strength parameters in the undrained state are hard to obtain through experimentation.

Undrained Poisson’s ratio and Skempton (B) coefficient are parameters used to calculate the bulk modulus of elasticity for water. The undrained Poisson’s ratio has a standard value of 0.495 with a compressibility of nearly ‘0 (zero)’ and the Skempton coefficient expresses the saturation, with 1 meaning full saturation.
## Step 02: Mesh > Material > UBC

### Material Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pref</td>
<td>Reference Pressure</td>
<td>In-situ horizontal stress at mid-level of soil layer</td>
</tr>
<tr>
<td>$K_G^e$</td>
<td>Elastic shear modulus number</td>
<td>Dimensionless</td>
</tr>
<tr>
<td>$n_e$</td>
<td>Elastic shear modulus exponent</td>
<td>Dimensionless</td>
</tr>
<tr>
<td>$\phi_p$</td>
<td>Peak Friction Angle</td>
<td>Failure parameter as in MC model</td>
</tr>
<tr>
<td>$\phi_{cv}$</td>
<td>Constant Volume Friction Angle</td>
<td>-</td>
</tr>
<tr>
<td>$C$</td>
<td>Cohesion</td>
<td>Failure parameter as in MC model</td>
</tr>
<tr>
<td>$K_G^p$</td>
<td>Plastic shear modulus number</td>
<td>Dimensionless</td>
</tr>
<tr>
<td>$n_p$</td>
<td>Plastic shear modulus exponent</td>
<td>Dimensionless</td>
</tr>
<tr>
<td>$R_f$</td>
<td>Failure ratio ($q_f / q_a$)</td>
<td>$0.7 - 0.98 (&lt; 1)$, decreases with increasing relative density</td>
</tr>
<tr>
<td>$F_{post}$</td>
<td>Post Liquefaction Calibration Factor</td>
<td>Residual shear modulus</td>
</tr>
<tr>
<td>$F_{dens}$</td>
<td>Soil Densification Calibration Factor</td>
<td>Cyclic Behavior</td>
</tr>
</tbody>
</table>

## Advanced Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pout</td>
<td>Plastic/Pressure Cutoff (Tensile Strength)</td>
<td>-</td>
</tr>
<tr>
<td>$K_p^p$</td>
<td>Cap Bulk Modulus Number</td>
<td>-</td>
</tr>
<tr>
<td>$m_p$</td>
<td>Plastic Cap Modulus Exponent</td>
<td>-</td>
</tr>
<tr>
<td>OCR</td>
<td>Over Consolidation Ratio</td>
<td>Normal stress / Pre-overburden pressure</td>
</tr>
</tbody>
</table>
Procedure

1. Main Menu Model > materials
2. [Create] > Select Isotropic.
3. ID ‘1’, Name ‘Embankment’, Model Type [Mohr Coulomb].
4. Enter the material properties as shown.
5. Click [OK].
6. Click [Apply].
7. Similarly create the materials for all the soil layers – Weathered Rock, Liquefaction, Soft Rock, and Abutment.
### Properties

<table>
<thead>
<tr>
<th>ID</th>
<th>Name</th>
<th>Type</th>
<th>Subtype</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Embankment</td>
<td>2D</td>
<td>Plane Strain</td>
</tr>
<tr>
<td>2</td>
<td>Liquefaction Layer</td>
<td>2D</td>
<td>Plane Strain</td>
</tr>
<tr>
<td>3</td>
<td>Weathered Rock</td>
<td>2D</td>
<td>Plane Strain</td>
</tr>
<tr>
<td>4</td>
<td>Soft Rock</td>
<td>2D</td>
<td>Plane Strain</td>
</tr>
<tr>
<td>5</td>
<td>Abutment</td>
<td>2D</td>
<td>Plane Strain</td>
</tr>
<tr>
<td>6</td>
<td>Pile</td>
<td>1D</td>
<td>Beam</td>
</tr>
</tbody>
</table>
1. Main Menu Model > Property
2. Click on [Add] > Select [1D].
3. ID ‘7’, Name ‘Pile’.
4. Element Type > [Beam].
5. Material > Steel’
6. Spacing 1.5m
7. Click-on ‘Sectional Library’
8. Select [Pipe], D > Enter ‘0.5’m, tw > enter ‘0.01’m.
9. Click [OK], Click [OK].
10. Repeat for 2D Plane Strain soil layers
1. Main Menu > Mesh > Generate > 2D > Auto Area
2. Select Object Edges > Select the edges as shown.
3. Mesh Size > Element Size ‘1’,
4. Property > Select ‘Embankment’ Name > ‘Embankment’.
5. Click [Advanced Option].
6. Type [Triangle], Check-off [Register Each Area Independently]. Click [OK].
7. Click [Apply].
8. Similarly create the mesh sets for Liquefaction, Weathered Rock, Soft Rock, & Abutment.
1. Main Menu > Mesh > Element > Extract Element
2. From Geometry > Select [Edge].
3. Select the 20 edges of the Pile as shown.
5. Mesh Set > Enter name ‘Piles’.
6. Click [OK]
1. **Main Menu** Display > Element Csys.
2. As can be seen the Element Csys are not aligned in the same direction. This will result in wrong display of results.
3. **Main Menu** > **Mesh** > Element > Change Element Parameter.
5. “Base Element” select any element whose Z axis is parallel to Global X-axis
6. Select the “Pile” mesh set from the works tree.
7. Click [OK].
1. Main Menu > Mesh > Element > Other > Ground Surface Spring
2. Select the 4 bottom ground layers as shown
3. Type the value of “2” for modulus of elasticity coefficient
4. Click [Apply].
The ‘Create Ground Surface Spring’ feature can generate automatically for dynamic analysis.

The modulus of subgrade reaction is calculated by equations in the ‘Create Ground Surface Spring’ feature.

\[
\text{Modulus of Vertical Subgrade Reaction: } k_v = k_{v0} \cdot \left( \frac{B_v}{30} \right)^{-3/4} \text{ (kgf/cm}^3)\]

\[
\text{Modulus of Horizontal Subgrade Reaction: } k_h = k_{h0} \cdot \left( \frac{B_h}{30} \right)^{-3/4} \text{ (kgf/cm}^3)\]

Where, \[k_{v0} = \frac{1}{30} \cdot \alpha \cdot E_0 = k_{h0} \cdot \sqrt{A_v} \cdot \sqrt{A_h} \]

\[\alpha: \text{Estimated factor for Modulus of subgrade reaction (use between 2.0~4.0)}\]
1. Main Menu > Analysis > General
2. Name ‘Eigen Value’, Analysis Type > Select [Eigenvalue].
3. Click-on Analysis Control [ ].
4. Water Level 2m Number of Frequencies ’30’.
5. Check ON: Sturm Sequence Check, Max Negative Pore Pressure (0), and Allow Undrained Behavior

Click [OK], Click [OK].
1. Main Menu > Analysis > Perform...
2. Check –on ‘EigenValue’.
3. Click [OK].
4. All the messages during the analysis will be shown in the Output Window. Especially, one needs to be very cautious about warning messages, because these messages indicate that the analysis results may not be correct. The model is automatically saved before the analysis. The result is saved as binary file(*.TA*) in the same folder as the model. The detail analysis information is also saved in a text file(*.OUT).
Step 10 Results > Vibration Mode

**Procedure**

1. Main Menu > Result > Vibration Mode Shape...
2. Check the periods of 1st and 6th modes where mass participation is the largest.
3. Keep the record of periods of 0.407 sec and 0.188 sec.
For the seismic analysis, users need to model infinite ground to eliminate the boundary effect caused by reflection wave. Since it is not possible to model infinite ground, users can apply Free Field Element at the boundary.

**Absorbent Boundary**: Enable to eliminate reflection wave at the ground boundary

**Width Factor (Penalty Parameter)**: In order to minimize the size effect of the model, users have to input more than $10^4$. This value will be multiplied by model width (In case of 2D, this is plain strain thickness (unit width)).
Step 11 Mesh > Element > Free Field

**Procedure**

1. Main Menu > Mesh > Element > Free Field
2. Select the 2 side boundary nodes
3. Select Property as Absorbent
4. Width Factor 1+e16
5. Click [Apply].
Step 11 Boundary for Free Field

Procedure

1. Tree Menu > Analysis > Boundary Conditions > Bottom Fix > Constraint > Edit
2. Select the 2 Free Field Elements
3. Delete the Ground Surface Spring
1. Return to the Pre Mode
2. Main Menu > Dynamic Analysis > Load > Ground Acceleration
3. Activate X direction and click icon
4. Add Time Functions
   Copy Paste function from Excel
5. Type Hachinohe in Name
6. Click OK
7. OK.
Step 13 Construction Stage

Procedure

1. Main Menu > Static / Slope Analysis > Construction Stage > Stage Set
2. Name: Liquefaction
3. Stage Type > Stress – Nonlinear Time History
4. Click > Add
5. Select “Liquefaction Set” from Table
6. Click > Define CS
Step 13 Construction Stage

Procedure

1. Stage name: Initial
2. Stage Type: Stress
3. Drag and Drop all data sets except Ground Surface Springs from Set Data to Activated Data
4. Set Water Level to 2m
5. Clear Displacement
6. Save > New
Step 13 Construction Stage

Procedure

1. Stage name: Time History
2. Stage Type: Time History
3. Drag and Drop Dynamic Load "Artificial" to Activated Data
4. Time Step > Define Time Step > Time Duration: 15s > Time Increment > 0.062 > Add
5. Analysis Control > General > Activate Undrained Behavior
6. Analysis Control > General > Dynamic > Damping Method
7. Select Calculate from Modal Damping, and Select Period [sec]
Enter the periods for 0.407s and 0.188s from previous eigenvalue analysis.
Enter 0.05 in Damping Ratio for both Mode 1 and 2
Click [OK] > [Save] > [OK]
Step 14 Analysis Stage

Procedure

1. Analysis > Case > General
2. Title: Liquefaction CS
3. Solution Type: Construction
   Stage > Liquefaction
4. Analysis Control >
5. General > Set as shown
6. Ok > Ok
Step 15 Analysis > Perform

Procedure

1. Main Menu > Analysis > Perform...
2. Check –on ‘CS’ only.
3. Click [OK].

All the messages during the analysis will be shown in the Output Window. Especially, one needs to be very cautious about warning messages, because these messages indicate that the analysis results may not be correct. The model is automatically saved before the analysis. The result is saved as binary file(*.TA*) in the same folder as the model. The detail analysis information is also saved in a text file(*.OUT)*.
Step 16 Results > Displacements

**Procedure**

1. Post Works Tree > Time History > Absolute Max > Relative Displacement > Total
Procure

1. Post Works Tree > Time History > Absolute Max > Beam Force Element > Axial Force
Procedure

Post Works Tree >
Time History >
Absolute Max >
Relative Accelerations >
Total Results > Extract >
Relative Acc TX >
nodes 19, 129, 849 >
Table > Graph

Procedure:

Step 16 Results > Accelerations
Procedure

Post Works Tree > Time History > Absolute Max > Plane Strain Stresses > Excessive Pore Stress Results > Extract > Excess Pore Stress > Abs Max > Table > Graph

- Plane Strain Stresses
  - S-XX TOTAL
  - S-YY TOTAL
  - S-ZZ TOTAL
  - S-XX
  - S-YY
  - S-ZZ
  - S-XY
  - S-MAJOR PRINCIPAL (V)
  - S-MINOR PRINCIPAL (V)
  - SAFETY FACTOR
  - S-MAX SHEAR
  - S-EQUIVALENT
  - S-VON MISES
  - PLASTIC STATUS
  - MEAN EFFECTIVE PRESSURE
  - MEAN TOTAL PRESSURE
  - PORE STRESS
  - EXCESSIVE PORE STRESS
**Step 16 Results > UBC Sand Results**

- **Pore Pressure Ratio (PPR)**
  - The ratio of excessive pore pressure change and the initial effective pressure
  \[
  PPR = -\frac{\Delta p'}{p_{init}} = \frac{p'_{init} - p'_{current}}{p_{init}}
  \]

<table>
<thead>
<tr>
<th>(\Delta p'_w)</th>
<th>Excessive Pore Pressure Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>(p'_{init})</td>
<td>Initial Effective Pressure</td>
</tr>
<tr>
<td>(p'_{current})</td>
<td>Current Effective Pressure</td>
</tr>
</tbody>
</table>

- **Normalized Max Stress Ratio**
  - The ratio of mobilized friction angle and the peak friction angle
  - When the Max stress ratio is reached, the mobilized friction angle is close to the peak friction angle, liquefaction is triggered (1 = Liquefaction)

\[
\text{max}\left(\frac{\sin \phi_m}{\sin \phi_p}\right)
\]

<table>
<thead>
<tr>
<th>(\phi_m)</th>
<th>Mobilized Friction Angle</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\phi_p)</td>
<td>Peak Friction Angle</td>
</tr>
</tbody>
</table>
End

Questions?

Global Help Desk
http://globalsupport.midasuser.com/helpdesk/